Mon blog-notes à moi que j'ai

Blog personnel d'un sysadmin, tendance hacker

Remplacer la Livebox Orange - Configuration d'un routeur Mikrotik pour Internet

En attendant mon nouveau routeur, j’ai bien entendu voulu configurer l’actuel pour remplacer la Livebox Orange, histoire de préparer le terrain.

Ayant constaté qu’Orange m’attribuait une IPv6 sur la Livebox, j’en ai déduis que j’étais connecté sur leur nouvelle infra réseau.
C’est important, car cela signifie que je n’ai plus besoin de mettre en place le client PPPoE, le DHCP suffit.

La plupart des tutoriels 1 concernent l’ancienne architecture réseau Orange. Ils sont néanmoins précieux en ce qu’ils couvrent plusieurs types de routeurs différents, ce qui aide à la compréhension globale du problème.
Un post sort du lot puisque consacré à la nouvelle architecture. Malheureusement, il ne concerne pas les routeurs Mikrotik :)

Préparatifs

Avant de se lancer à corps perdu dans la configuration du routeur, il faut rassembler un certain nombre d’informations dont nous aurons besoin:

Login Orange
Au format fti/xxxxxxx, nous aurons besoin des xxx pour compléter les options DHCP, au format héxadécimal.
A priori, le mot de passe n’est pas utilisé, en tout cas pour Internet.
Adresse Mac Livebox
Je ne sais pas exactement si elle est nécessaire, mais dans le doute, je vais l’utiliser sur le Mikrotik

DHCP options

Les options varient selon les publications sur les forums. En commun, on retourve les options 77 & 90

option 77 name userclass
2b:46:53:56:44:53:4c:5f:6c:69:76:65:62:6f:78:2e:49:6e:74:65:72:6e:65:74:2e:73:6f:66:74:61:74:68:6f:6d:65:2e:4c:69:76:65:62:6f:78:33, en hexa 0x2b46535644534c5f6c697665626f782e496e7465726e65742e736f66746174686f6d652e4c697665626f7833
option 90 name authsend
00:00:00:00:00:00:00:00:00:00:00:00:66:74:69:2f:XX:XX:XX:XX:XX:XX:XX, en hexa 0x0000000000000000000000006674692fXXXXXXXXXXXXXX. N’oubliez pas de remplacer XXXXXXXXXXXXXX par votre login fti/ comme indiqué plus haut.

Dans certains cas, on trouve également l’option 60. Je n’en ai pas eu besoin, mais au cas où la voici

option 60 name vendor-class-identifier
sagem, en hexa 0x736167656d

Configuration du routeur Mikrotik

Dans mon cas, l’interface ether1 du routeur sera le lien upstream vers Orange. L’interface ether10 accueillera le lien upstream de ma connexion ADSL que j’ai toujours pour le moment. Les autres interfaces sont regroupées en 2 switch. ether2 est le master port pour le switch 1, ether6 pour le switch 2.
Le nommage des interface en ethX permet d’avoir le même nom que ce qui est inscrit sur le routeur lui-même.

La configuration de l’ADSL ne sera pas couverte ici, pas plus que celle du bridge LAN.

Configuration des interfaces ethernet

/interface ethernet
set [ find default-name=ether1 ] master-port=none name=eth1 mtu=1492 l2mtu=1598 mac-adress=yy:yy:yy:yy:yy:yy speed=1Gbps
set [ find default-name=ether2 ] master-port=none name=eth2
set [ find default-name=ether3 ] master-port=none name=eth3
set [ find default-name=ether4 ] master-port=eth3 name=eth4
set [ find default-name=ether5 ] master-port=eth3 name=eth5
set [ find default-name=ether6 ] master-port=none name=eth6
set [ find default-name=ether7 ] master-port=eth6 name=eth7
set [ find default-name=ether8 ] master-port=eth6 name=eth8
set [ find default-name=ether9 ] master-port=eth6 name=eth9
set [ find default-name=ether10 ] master-port=none name=eth10

Configuration du vlan 832 sur ether1

/interface vlan
add interface=eth1 name=vlan832-orange vlan-id=832 mtu=1492 arp=enabled use-service-tag=no

Configuration IPv4

Configuration du NAT en sortie

/ip firewall nat
add action=masquerade chain=srcnat out-interface=vlan832-orange to-addresses=0.0.0.0

Configuration des options DHCP. Ces options servent à authentifier le routeur côté Orange

/ip dhcp-client option
add code=77 name=userclass value=0x2b46535644534c5f6c697665626f782e496e7465726e65742e736f66746174686f6d652e4c697665626f7833
add code=90 name=authsend value=0x00000000000000000000006674692fxxxxxxxxxxxxxx

Configuration du client DHCP pour Orange avec les options

/ip dhcp-client
add interface=vlan832-orange disabled=no add-default-route=yes default-route-distance=1 use-peer-dns=yes use-peer-ntp=yes dhcp-options=hostname,clientid,authsend,userclass

Certain tutoriels précisent également l’option 60 vendors-class-identifier. Je n’en ai pas eu besoin, mais au cas où, voici ce que cela donne:

/ip dhcp-client option
add code=60 name=vendor-class-identifier value=0x736167656d

/ip dhcp-client
add interface=vlan832-orange disabled=no add-default-route=yes default-route-distance=1 use-peer-dns=yes use-peer-ntp=yes dhcp-options=hostname,clientid,authsend,userclass,vendor-class-identifier

Configuration IPv6

Je ne suis malheureusement pas parvenu à faire fonctionner l’IPv6. Il semble que le client DHCPv6 intégré au Mikrotik ne supporte pas l’ajout d’options, visiblement nécessaires pour être « authentifié » sur le réseau IPv6 Orange.

Conclusion

Une fois la configuration réalisée, on obtient une adresse IPv4 et on peut réaliser les tests de bande passante.
Le premier test réalisé était plutôt décevant: je montais péniblement à 100Mb/s.

Tests de débit sur la fibre Orange, à partir d'une interface 100Mb du routeur. Serveur de test Orange

J’ai au départ incriminé le routeur, dont le CPU à 600MHz me paraissait difficilement capable de monter au delà, avant de m’apercevoir que l’upstream Orange était branché sur une interface 100Mb… :-D
Une fois branché sur une interface Giga, le test est monté à un peu plus de 300Mb/s en download et environ 230Mb/s en upload.

Tests de débit sur la fibre Orange, à partir d'une interface Giga du routeur. Serveur de test Orange

Pas si mal, mais très en deça des tests réalisés avec la Livebox.

Vivement l’arrivée du nouveau routeur donc \o/